PhpStormで対応 JavaScript のバージョンを上げる

Let definitions are not supported by current Javascript version」、Letには対応してないよ、と言われるので PhpStorm で使用するJavascript のバージョンを上げる。

 

表示されるメッセージ

英語

「Let definitions are not supported by current Javascript version」

 

 

 

日本語

「現在の JavaScript バージョンでは Let definitions はサポートされていません」

 

設定する

PhpStormの設定画面を開く

Languages & Frameworks > JavaScript

ここでJavaScript のバージョンを変更できる。

英語

 

日本語

 

結果

let の下の波線は消えた。

 

 

 

試したver:PhpStorm2017.3

コメント